注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

linux 学习

 
 
 

日志

 
 

PHP扩展源码安装小插曲  

2012-05-10 11:46:06|  分类: PHP |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
平台:Ubuntu9.10、Apahce2.2.14、PHP5.3.1
PHPize是什么?
根据PHP Api Version等生成configure文件的工具。这样,生成的动态连接库文件(*.so,或者说Modules)就与该PHP Api兼容。经过源码编译、安装PHP之后,在bin/下面就有phpize以及php-config。我们使用这个phpize以及php- config,生成的模块就能与该PHP兼容。
我因为不懂phpize,接着阴差阳错地犯了下面这个错误,
错误信息(httpd.conf):
PHP Startup: mbstring: Unable to initialize module
51 Module compiled with module API=20060613
52 PHP    compiled with module API=20090626
53 These options need to match
phpize显示:
PHP Api Version: 20060613
Zend Module Api No: 20060613
Zend Extension Api No: 20060613

网上没找到准确的解决办法,,这个错误把我折磨了两天。今天总算解决了,希望对同病相怜的人有所帮助。上面红色标注的信息,给了我很大的提示。
我忘记了ubuntu上已经通过apt-get安装了PHP,当然也包含phpize。当我用phpize去生成配置文件的时候,调用的系统的原先安装的phpize,所以PHP Api Version就是20060613。而我通过源码安装的PHP Api Version是20090626,理所当然就出现了"Module compiled with module API=20060613,PHP compiled with module API=20090626"这种错误。所以在通过源码安装完PHP以后,最好能将php安装目录下的bin添加到环境变量中去,或者添加一个alias。

  评论这张
 
阅读(2356)| 评论(1)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018